Memorandum

javaコマンドラインツールを使用するには、JDKをインストールする必要があります

Webカテゴリーでもないのだが備忘録。

Google Chrome ver 46.0.2490.86 (64-bit)を利用しているのだが、El Capitanにアプデしたら表題のようなエラーが頻出するようになってしまった。詳細のページに飛んでプラグインをDLしても解決しない。

We have detected you are using Google Chrome and might be unable to use the Java plugin from this browser. Starting with Version 42 (released April 2015), Chrome has disabled the standard way in which browsers support plugins.

「Google Chromeを使用してる場合、このJavaプラグインを使用することができない可能性があります。 ( 2015年4月発売)バージョン42以降では、 Chromeがサポートプラグインを無効にしています。」とのことで、さらに詳細を見てみるとChromeがVer45以降、NPAPIのサポートをやめたのでFlashとかSilverlightとか動かなくなるかもよ、と。しぶしぶメインブラウザをSafariに変更したものの出続けるのですよね。

で、下記インストールして解決。

Java for OS X 2015-001